Ruby-core deixa de suportar Bundler em versões antigas do Ruby, incluindo a utilizada no Openredu 1.9.3

Pessoal,

Tenho colaborado com a comunidade apoiando instalações do Openredu em diversas instituições.

Praticamente todas que entram em contato para utilizar o Openredu e solicitam ajuda, preferem utilizar a versão tradicional de instalação, e não a versão dockerizada. Pois não utilizam e não pretendem em curto prazo utilizar docker em sua infraestrutura.

Para facilitar a manutenção do servidor junto as equipes de infraestrutura dos parceiros, adotei esse virtual appliace:

https://www.turnkeylinux.org/nginx-php-fastcgi

E apartir dele instalo o Ruby, Rails, o Openredu e faço as configurações com Nginx.Tudo estava funcionando bem, com vários cases de sucesso, porém desde do início deste ano não estou mais conseguindo avançar nas instalações, mesmo utilizando o ambiente de sempre, o erro que apresenta é esse:

ERROR: Error installing bundler:
bundler requires Ruby version >= 2.3.0.

Aparentemente houve uma mudança no ruby-core e não estão mais suportando Bundler com versões antigas do Ruby, como a utilizada no Openredu a 1.9.3, conforme pode ser visto nessa postagem: https://github.com/bundler/bundler/issues/6865

Bundler 2 no longer supports versions of Ruby that are so old they have been abandoned by the ruby-core team. That includes Ruby 2.2 and older. This is intended behavior, sorry.

Existe alguma versão do Openredu com correção desse problema?

Essa é uma dificuldade que impacta diretamente em novas implantações.

2 Curtidas

Pessoal, informo que consegui avançar na instalação executando os seguintes comandos:

gem install rubygems-update -v 2.7.8
update_rubygems
gem install bundler -v 1.17.3

Essa é uma solução paliativa, até seja atualizado o Openredu para uma versão mais atual do Ruby.

1 Curtida